DevTeam Updates PwnageTool for Mac, iPhone 3.1.2 Now Supported

PwnageTool for Mac has been updated to version 3.1.4 by the DevTeam. This new update basically adds firmware 3.1.2 jailbreak support. It currently supports jailbreaking all the devices except iPod Touch 3G.

Pwnage_3.1.4_3.1.2

PwnageTool is currently compatible with Intel Mac only. The reason some would prefer it to blackra1n is that it allows you to ‘hacktivate’ the phone (use it without AT&T’s iPhone data plan) and the unlock is preserved even through firmware updates. However, to unlock an iPhone 3G or iPhone 3GS, make sure that you have a firmware 3.0 (or 3.0.1) baseband on the phone. Then, you can simply update to a custom 3.1.2 IPSW, created using PwnageTool. After updating, just install ultrasn0w from Cydia to unlock. Those who already upgraded to 3.1.x and then used blackra1n to jailbreak can no longer unlock for quite a while.

You can even make a transition from blackra1n jailbreak to the PwnageTool one, if you are having issues with WinterBoard or MobileSubstrate on your jailbroken device. For this, make a custom IPSW using PwnageTool 3.1.4. Open iTunes and press option key + select restore (or Shift key + Restore on Windows) and then select the custom firmware to restore. Just make sure that you do NOT enter DFU mode. This way, you will be jailbroken using the PwnageTool and shouldn’t have such issues any longer.

Before you finally use the tool, just have a look at these ‘Golden Rules’

  1. GOLDEN RULE: If you are using a iPhone 3G or iPhone 3G(S) with ultrasn0w and rely on ultrasn0w to obtain cellular service then you should only update your device with an .ipsw that is made with the new PwnageTool. There are no second chances with this. You need to remember that PwnageTool will provide an upgrade path to newer versions of the iPhone software in the future.
  2. Please read all parts of this post before downloading and using these tools.
  3. Read items 1, 2 and 3 again and again.
  4. At the bottom of this post are the bittorrent files for the 3.1.4 capable version of PwnageTool.
  5. PwnageTool will work for the iPhone 3GS
  6. PwnageTool will work for the iPod touch 2G
  7. PwnageTool WILL work for Original iPhone (1st Generation), the iPhone 3G and iPhone 3G(S) and the iPod touch (1st Generation and 2nd Generation) but NOT the iPod touch 3rd generation.
  8. For 3G and 3G(S) users who are Pwned, PwnageTool is your key to updating in the future, just remember to never install an update directly from Apple, always use an .ipsw that has been created with PwnageTool.
  9. There is no Windows version of PwnageTool it is a Mac OS X tool only, we are not developing a Windows version of PwnageTool.

The latest PwnageTool for Mac is available to download from torrents. [SHA1= d9d44258ade35623ec71e83520943b6f4baa568a]

Related

About the author

Sayam AggarwalSayam Aggarwal is a 18-year-old student living in India who has been an Apple fan for almost 5 years. He has worked with ModMyi, one of the leading iPhone communities, as an author for more than a year. He spends most of his free time on the Internet fetching the latest news regarding Apple and its entire product range. Follow him on Twitter!

(sorry, you need Javascript to see this e-mail address)| Read more posts by .

Posted in iPhone, iPhone 3G, iPhone 3G S, iPod Touch, News |